ひっさびさにVagrantを動かしたところ、なんかうまく動かなくなってたんで再インストールしました。

手順としては、
1)Vagrant用のディレクトリを作成する
2)$ vagrant init parallels/centos-7.3
3)$ vagrant up –provider=parallels
っで、チャンチャンな予定だったんですが、こんなエラーが。。。

/opt/vagrant/embedded/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require’: incompatible library version – /Users/hogehoge/.vagrant.d/gems/2.4.4/gems/nokogiri-1.8.2/lib/nokogiri/nokogiri.bundle (LoadError)

な、なんだこれは!
ってことで、”vagrant incompatible library version”でググってみると、plugin を再インストールしましょうとの記事が。。

$ vagrant plugin expunge

Would you like Vagrant to attempt to reinstall current plugins? [N]: y

This command permanently deletes all currently installed user plugins. It
should only be used when a repair command is unable to properly fix the
system.

Continue? [N]: y

All user installed plugins have been removed from this Vagrant environment!

Vagrant will now attempt to reinstall user plugins that were removed.
Installing the ‘vagrant-parallels’ plugin. This can take a few minutes…
Fetching: mini_portile2-2.4.0.gem (100%)
Fetching: nokogiri-1.10.1.gem (100%)
Building native extensions. This could take a while…
Fetching: vagrant-parallels-2.0.0.gem (100%)
Fetching: vagrant-share-1.1.9.gem (100%)
Installed the plugin ‘vagrant-parallels (2.0.0)’!
Installing the ‘vagrant-share’ plugin. This can take a few minutes…
Installed the plugin ‘vagrant-share (1.1.9)’!

ってことで、無事にvagrant upできるようになりました。